avatar
Sexe : Féminin
Date d'inscription : 30/11/2017
Messages : 36
Bonsoir,


Quelle structure est concernée par votre problème ? chatbox
Qu'elle est l'adresse du forum concerné (sous hide si cela vous dérange) ? http://levi-vs-libra-corpus.forumactif.com/
Un screen du problème : éventuellement, si aide à la compréhension
Spoiler:
Expliquez précisément votre problème : Donc comment expliquer. Sur un autre forum ou je suis inscrite, lorsqu'on poste un message sur la cb, cela s'affiche sur la barre de navigation la ou sur ma photo il y a marqué les trois "forums". J'avais essayé de différents codes, mais je n'arrive pas à le faire marcher, donc je préfère demander ici, si c'est possible.
Les codes :
C 'est le code de Dita avec quelques petits changements.


Code:
</span> jQuery(document).ready(function() { jQuery('body').append('<div style="overflow: visible; position: fixed; bottom: 180px; height: 350px; left: 0px; z-index:1000;"><iframe src="http://levi-vs-libra-corpus.forumactif.com/chatbox/index.forum" id="chatboxpop" scrolling="yes" style="overflow: visible; width: 750px; height: 350px; display: none; float:left;" marginwidth="0" marginheight="0" frameborder="0"></iframe><div onClick="jQuery(\'#chatboxpop\').animate({width:\'toggle\'},1200); jQuery(\'#chatboxopen,#chatboxclose\').toggle();" style="margin-top: 0px; cursor :pointer; float:left"><img src="https://i62.servimg.com/u/f62/14/55/33/08/chatbo11.jpg" id="chatboxopen"/><img src="https://i62.servimg.com/u/f62/14/55/33/08/chatbo11.jpg" id="chatboxclose" style="cursor :pointer; display:none;"></div></div>'); } );

S'il n'y a pas moyen de le faire merci quand même. Benficagirl
avatar
Sexe : Féminin
Date d'inscription : 26/12/2013
Messages : 3008

Fiche Membre
Lots gagnés:
Designer en stage
Voir le profil de l'utilisateur
Bonjour, je te réfère au site de forumactif pour obtenir les effets voulus (:
http://forum.forumactif.com/t376396-codes10-pour-la-chatbox


avatar
Sexe : Féminin
Date d'inscription : 30/11/2017
Messages : 36
Merci

J'ai essayé avec ce code mais peut-être je l'avais mal placé :/ en tout cas cela ne marchait pas :/.

celui là :

Code:
window.localStorage && $(window).load(function() {
  var chatbox_script = function() {
    var t_icon = window.top.$.find('link[rel="shortcut icon"]')[0];
    var t_doc = window.top.document;
    var title = t_doc.title;
    var icon = t_icon.getAttribute('href');
 
    var rep_title = '!! Nouveau message !! '+title;
    var rep_icon = 'http://illiweb.com/fa/fdf/al.ico';
 
    $(window).on("focus", function(){ localStorage.cb_blurred='' }).on("blur", function(){ localStorage.cb_blurred=1; });
    var overrided = Chatbox.prototype.refresh;
    Chatbox.prototype.refresh = function(data) {
      if (data.messages && data.messages.length) {
        var lm = data.messages.slice(-1)[0];
        var last_message = lm.time+','+lm.action+','+lm.msg;
        if(this.last_message != last_message) {
          var user = $.grep(data.users, function(v){return v.id==chatbox.userId});
          user = user.length ? user[0] : [{}];
          if(this.last_message!==undefined) {
            if(lm.userId!=chatbox.userId && user.username!=lm.username) {
              if(localStorage.cb_blurred) (function(){
                var blink = function(){
                  if(title == t_doc.title) {
                    if(!localStorage.cb_blurred) return;
                    var new_title = rep_title;
                    var new_icon = rep_icon;
                  } else {
                    var new_title = title;
                    var new_icon = icon;
                  }
                  t_doc.title = new_title;
                  var new_t_icon = t_icon.cloneNode(true);
                  new_t_icon.setAttribute('href', new_icon);
                  var t_icon_parent = t_icon.parentNode;
                  t_icon_parent.removeChild(t_icon);
                  t_icon_parent.appendChild(new_t_icon);
                  t_icon = new_t_icon;
                  setTimeout(blink, 500);
                };
                blink();
              })();
            } else {
              localStorage.cb_blurred='';
            }
          }
          this.last_message = lm;
        }
      }
      overrided.call(this, data);
    };
  };
  var s=document.createElement('script');s.text="("+chatbox_script.toString()+")();";$('object[data^="/chatbox/index.forum"],iframe[src^="/chatbox/index.forum"]').each(function(){try{$(this.contentDocument||this.contentWindow.document).find("#chatbox").closest("html").find("head").first().each(function(){this.appendChild(s.cloneNode(true))})}catch(a){}})
});

avatar
Sexe : Féminin
Date d'inscription : 26/12/2013
Messages : 3008

Fiche Membre
Lots gagnés:
Designer en stage
Voir le profil de l'utilisateur
Tu l'as bien mis dans Panneau d'administration > modules > HTML & JAVASCRIPT > Gestion des codes Javascript
Tu as bien activé le JS sur ton forum et tu as bien coché ¨sur tout le forum¨ ?



avatar
Sexe : Féminin
Date d'inscription : 30/11/2017
Messages : 36
oui j'avais tout fait :/ la je viens de l'enlever je dois regarder peut-être il y a quelque parts d'autre un forum :/ je vais encore une fois vérifier tous les codes :/.
avatar
Sexe : Féminin
Date d'inscription : 15/12/2012
Messages : 4107

Fiche Membre
Lots gagnés:
Admin' / Designer
Voir le profil de l'utilisateurhttp://sarahdealerevans.deviantart.com/gallery/
Coucou :)

Est-ce que tu as d'autres scripts actifs dans la gestion de tes codes Javascript dans ton panneau d'admin ?
Contenu sponsorisé
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum